Currently column names containing characters that would requiring escape will be replaced with generic names (e.g. col0). We should attempt to preserve the name only replacing the mismatched characters.
'model-number' would be 'model_number'
'3descript' would be '_descript'
We will fallback on the generic col# naming if generated name is not accepted.