maven version requirement should be explicit

Description

Maven build has an implicit build requirement from the use of some dependent plugins. This version requirement should be made explicit at the root pom, for a fail fast response for non-compliant build environments.
e.g.

1 [ERROR] Failed to execute goal net.alchim31.maven:scala-maven-plugin:3.4.4:add-source (scala-compile-first) on project kylo-commons-spark-livy: The plugin net.alchim31.maven:scala-maven-plugin:3.4.4 requires Maven version 3.3.9

Environment

None

Status

Assignee

Tim Harsch

Reporter

Tim Harsch

Labels

None

Reviewer

None

Story point estimate

None

Epic Link

Components

Affects versions

0.10.0

Priority

Medium
Configure