unable to load data from JDBC datasource on Kylo-UI

Description

Hi Team,

I have setted up Kylo 0.10.0 on AWS EC2 edge node(centos machine) and configured with AWS EMR(1 Master node m3.xlarge) having configuration details as below:

1) Release label: emr-5.15.0
2) Hadoop distribution: Amazon 2.8.3
3) Applications: Hive 2.3.3, Pig 0.17.0, Hue 4.2.0, Spark 2.3.0, Tez 0.8.4, HBase 1.4.4, Sqoop 1.4.7, HCatalog 2.3.3, Livy 0.4.0, Flink 1.4.2

I followed this link to install: https://kylo.readthedocs.io/en/v0.10.0/installation/EMR5.15PersistentClusterWithEdgeNode.html.

I have configured AWS Glue catalog instead of using hive metadata. I had created a hive2 jdbc connection for a Hive database on Kylo UI that's not fetching data into tables.
JDBC Hive dataSource fetched databases list and tables name fine but it isn't able to load data on Catalog and Wrangler page.

I got below error when I tried to fetch data into table everytime

http-nio-8420-exec-6:SparkShellProxyController:984 - An error occurred while executing the transformation.: com.thinkbiganalytics.kylo.spark.SparkException: javax.script.ScriptException: org.apache.spark.sql.AnalysisException: Cannot resolve column name "demo15_feed.lastname" among (demo15_feed.lastname, demo15_feed.firstname, demo15_feed.ssn, demo15_feed.phone, demo15_feed.company, demo15_feed.email, demo15_feed.city, demo15_feed.zip, demo15_feed.previouscompanyid, demo15_feed.salary, demo15_feed.bonus, demo15_feed.employmentdate, demo15_feed.departmentid, demo15_feed.processing_dttm)

I posted this issue on Kylo Community forum. It seems like that's a bug in kylo as I have attached images of our discussion and on below link you may find our discussion as well.

https://groups.google.com/forum/?utm_medium=email&utm_source=footer#!topic/kylo-community/hWd4vFW43lk

Environment

None

Status

Assignee

Unassigned

Reporter

Umar Shabbir

Labels

None

Reviewer

None

Story point estimate

None

Priority

Highest