The instructions for Quickstart using the Sandbox are incorrect

Description

Currently the Quickstart page on kylo.io describes the process for using the downloadable virtual machine as:

  1. Download Kylo Sandbox for VirtualBox

  2. In VirtualBox: File | Import Appliance

  3. Start VM and allow up to 10 minutes to start services

  4. From web browser: Kylo Ops Manager | Kylo Feed Manager

  5. Application login: dladmin/thinkbig, Sandbox OS login: root/kylo

Step 3 is incorrect, or at least misleading - the services within the virtual machine have to be manually started via Ambari.

Activity

Show:
Jeremy Merrifield
July 20, 2017, 1:58 PM

OK. Can you please try two more things? Can you please restart your Mac? Then startup a clean version of the VM. I have seen Virtual Box get wrapped around the axle a few times. If that still doesn't fix it can you please try upgrading to the latest version of Virtual Box. I might have built the VM with a slightly newer version of Virtual Box and maybe there is an issue with the VM tools that is installed.

Thanks !

Robert Hook
July 20, 2017, 3:43 PM

Ok, here's what I've done:

  1. updated to the latest virtual box (5.1.24-117012-OSX), and added the latest extension pack (5.1.24-117012)

  2. cloned the 0.8.2 sandbox VM I downloaded a few days ago and launched it

  3. waited 10 minutes

  4. put my head in my hands and wept because it now works

So it looks like there could be some dependency, as you suggested, on the version of Virtual Box and/or the VM extensions pack. We may need to ensure that the Quickstart guide specifies 5.1.24 and the extension pack as a required minimum.

I'll note that the services all restart successfully after the VM itself is rebooted using `shutdown -r now`, so whatever magic is in play is now playing happily.

Jeremy Merrifield
July 20, 2017, 6:19 PM

Thanks a lot Robert. I built it with 5.1.22 but it may have been a newer revision. I will make sure we update the web site with the latest version we built with so folks now. Thanks again for testing !

Jeremy Merrifield
July 20, 2017, 10:45 PM

I added a note to the quickstart page to let folks know they need 5.1.24 or later

Ibn Sinha
September 13, 2019, 4:38 PM

I am not able to download the Kylo sandbox. It gives me access denied.

Assignee

Jeremy Merrifield

Reporter

Robert Hook

Labels

None

Reviewer

None

Components

Sprint

None

Fix versions

Priority

Medium
Configure